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Advanced Photosho
- Layers, typography, design & workflow

Layers

Layers let you separate an image into independent elements — vector shapes, image adjustments, text and ordinary image
pixels — all these can kept in a layer and edited and moved without effecting the rest of the image.

Layers are stacked one on top of the other and can contain transparent and semi-transparent areas that reveal the contents
of lower layers.

Transparent areas in a layer can be displayed as a checkerboard pattern when there are no underlying layers.This default can
be changed by going to EDIT>PREFERENCES>TRANSPARENCY & GAMUT..

Layers can also be grouped together and treated as a single unit by creating Layer Sets.

Select Layers or Layer Sets by clicking on their name in the Layers palette or by right clicking with the Move tool selected in
the image window.

The Background Layer

When you open an image generally you'll find that its bottommost layer is labelled Background.The Background Layer is
always the exact dimensions of the image, is opaque and cannot be moved.

If you need to convert a Background layer into an ordinary layer either use LAYER>NEW>LAYER FROM
BACKGROUND or double click on the Background Layer in the Layer palette.

You can also convert the other way. If your document has no Background layer and you want to create one, first select the
layer you'd like to become the Background.Then got to LAYER>NEW>BACKGROUND FROM LAYER.

The Layers Palette

The layers palette allows you to create, link, hide, delete, merge, duplicate, mask, name, colour code and add special effects to
layers and layer sets.

_m\ . Creating Layers
Morrnal W | Cpacity: [100% * Make a new empty layer using LAYER>NEW>LAYER (SHIFT-
. @ T CRTL-N) . Or click on the Create a New Layer icon E].
e Zl T Start a new layer from an existing selection with LAYER>NEW>LAYER
: VIA COPY (CRTL-J) or LAYER>NEW>LAYER VIA COPY.
- Effects (CRTL-SHIFT-J) The first copies the selected pixels on to a new
&  Crop Shadow layer, the second cuts the original pixels and then copies them to a new layer
leaving a hole behind it.
- WE-

Also, whenever you use the Paste command (EDIT>PASTE) (CTRL-V)

& El i Earae you create a new layer.
—

® D 8 g s Selecting Layers

Select layers by clicking on them in the layer palette. Alternately RIGHT -
CLICK (CTRL-CLICK on the Mac) in the document window.This will
display a contextual menu containing the name of all the layers beneath your
cursor.

6.0 O ® & §]

Deleting Layers

Delete layers by dragging them to the dustbin icon on the layers palette. Or by clicking on the dustbin icon . Or by using
LAYER>DELETE>LAYER. Or by right clicking on it’s name in the layers palette. Or by using LAYER PALETTE
SUBMENU>DELETE LAYER. Orby...
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Duplicating Layers

Duplicate layers by dragging a layer name on to the New Layer icon on the Layers palette. Or by using
LAYER>DUPLICATE LAYER.. Or by right clicking on it’s name in the layers palette. Or by using LAYER
PALETTE SUBMENU>DUPLICATE LAYER.

Hiding/Showing Layers

You can control the visibility of layers by turning them on and off via the “eye” column of the Layers palette. ALT-Clicking an
eye, makes visible the active layers and turns off all other layers

Grouping & Layer Sets

Group layers together by clicking into or dragging through the link column (the column sitting next to the visability eye icons)
of layers you want to link together.

Unlink by clicking on the chain icon in the link column of a linked layer. |

Create Layer Sets to organise and group related layers as well as to save space in the Layers palette.To make a new empty
Layer Set go to LAYER>NEW>LAYER SET or click on the New Layer Set icon on the Layers Palette _].

Create Layer Sets from already linked layers by choosing Layer>New>Layer Set from Linked... or by finding the same
command in the Layer palette submenu.

Merging & Flattening Layers

There are a few options for merging layers together.

The Merge Down command merges the active layer with the one below it. Find this command under LAYER>MERGE
DOWN, the Layer palette submenu or use CTRL-E.

If you’ve an active layer with other layers linked to it Merge Linked, found under LAYER>MERGE LINKED and the
Layer palette submenu, merges the linked layers.. (And you can use CTRL-SHIFT-E)

If you've not got any linked layers Merge Visible merges all visible layers. Find this command under LAYER>MERGE
VISIBLE, the Layer palette submenu or use CTRL-SHIFT-E.

You can also merge all existing, visible layers into a single Background layer by choosing Flatten Image from
LAYER>FLATTEN IMAGE or by looking for the same command in the Layers palette.

Naming & Organising Layers

Name layers by double-clicking on the layers name in the Layer palette. Alternatively right click on the Layer in the layer
palette and choose Layer Options. Or go to the Layers palette submenu and choose Layer Options.

The Layer options dialogue box also lets you apply colour coding to the layer palette to help keep track of groups of layers.

Moving, Reordering & Aligning Layers

Layers can be activated and moved with the Move tool.

Reorder the stacking order of Layers or Layer Sets by dragging them up or down the Layer palette.Alternatively use CTRL—
[ OR CTRL-] to send an active Layer one notch up or down the stacking order. CRTL-SHIFT-[ and CRTL-
SHIFT-] will take a layer all the way to the top or the bottom of the stacking order.

Linked layers can be aligned and distributed in relation to each other using the various alignment and distribution commands.
You only have access to these commands when you have the Move tool selected.

e Aligns the top edges of selected layers

= Aligns the vertical centres of selected layers
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Ha Aligns the bottom edges of selected layers

|

|I:I Aligns the left edges of selected layers

E%I Aligns the horizontal centres of selected layers

]
|:|| Aligns the right edges of selected layers

=
=T Evenly distributes the top edges of selected layers

===
“—=+ Evenly distributes the vertical centres of selected layers

e
L1 Evenly distributes the bottom edges of selected layers
ap Evenly distributes the left edges of selected layers

A Evenly distributes the horizontal centres of selected layers

dd Evenly distributes the right edges of selected layers

Selecting Layer Content

To select the content of a layer and to exclude any transparent areas, CTRL-CLICK on a layer in the Layer palette.

Locking Layers

You can lock various aspects of a layer with these icons from the Layers palette.
Lock Transparency

7 Lock Pixels

“* Lock Position

B Lock Al

Transforming Layers

Scale, distort, skew, flip etc using the EDIT>FREE TRANSFORM. (CTRL-T). Free Transform command will only affect
the selected layer — unless there’s a selection active in which case it'll affect just that instead.

*  Scale — Drag with the resize handles. SHIFT-DRAG to stop distortion.

*  Flip — Flip the layer either vertically or horizontally by RIGHT-CLICKING within the Free Transform
rectangle. (CONTROL-CLICK on the Mac).

* Rotate —Take your cursor outside the Free Transform rectangle and DRAG.

* Skew — CTRL-DRAG a corner resize handle.

e Distort — CTRL-DRAG on any corner resize handle.

*  Perspective - CTRL-SHIFT-DRAG a corner resize handle.

Layer Opacity

Layer opacity can be controlled via the opacity slider at the top of the Layers palette. If you have the Move tool selected
opacity can be set for the active layer by using the number keys 1-0 (I = 10,0 = 100).

Layer Masks

You can add masks to your layers or layer sets to hide or reveal the layers content.

A layer mask is an eight-bit channel like a quick mask. Paint with black on a mask to hide portions of a layer — paint in white
to reveal them — intermediate shades of grey represent intermediate levels of opacity.
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Add a layer mask by clicking on the Add Layer Mask icon on the Layer palette. ﬂ

When a layer mask is active it has a slightly thicker border around it’'s thumbnail, and the words Layer Mask are added to the
images title bar.

You can use any of Photoshop’s paint tools, gradients or filters in a layer mask.

If you've a selection active when you create a new layer mask Photoshop automatically fills the selected areas in the mask
with white and the unselected areas with black, effectively hiding the areas not included in the selection marquee.

To view a layer mask independently of the layer it's masking ALT—-CLICK its thumbnail in the Layer palette.
Temporarily turn off a layer mask by SHIFT-CLICKING on the mask’s thumbnail.

Switch between the active layer and it’s layer mask by using CTRL—\ to jump to the layer mask and CTRL—~(tilde) to go
to activate the layer itself.

Vector Masks

A vector mask is very similar to an ordinary layer mask but instead of an eight-bit channel layers are masked by using a vector
shape.

To create a vector shape first create a work path, next select the layer you want to mask then go to LAYERS>ADD
VECTOR MASK>CURRENT PATH.

Edit the vector mask using the pen tool and it’s associates.

Clipping Groups

Use the opaque areas in one layer to create a mask for one or more layers by creating Clipping Groups.

To create a Clipping Group move the layer you wish to use as a mask beneath the layers you want to be affected by the mask.
Then ALT-CLICK on the line between the layer you want as a mask and the layer above it.

ALT-CLICK on the lines between other layers to include them in the clipping group.

Shape Layers

As well as normal pixel based layers Photoshop also supports vector based shape layers. Shapes are created using either the
pen tools or the preset shapes.

Creating Shape Layers

Shape layers are created by selecting one of the pen tools or a preset vector shape and click the Shape Layers button in the
options bar. [ L]

Drawing an initial shape creates a shape layer.The layer is made up of a fill — either a flat colour, a pattern or a gradient — and
a vector mask, both represented by thumbnails on the Layers palette.

Transforming & Modifying Shape Layers

Shape layers can be moved and transformed using the Move tool and Free Transform respectively.

Change the colour fill of a shape layer by double-clicking on the layer fill thumbnail, or by changing the colour fill on the
options bar or by selecting a new Foreground colour and then applying ALT-DELETE.

Alter the type of fill in a shape layer by going to Layer>Change Layer Content.

Combining Shape Layer Components

Once a shape layer has been created additional path components can be added to it using the shape and pen tools.The path
compound buttons on the options palette determine the way these shapes interact with each other.
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A hot really a compound button at all! Makes a new layer with a new shape on it.

5 2dd new areas to the shape layer

g

subtract areas from the shape layer

=1 fills the shape layer only in the areas where a new path intersects with the other paths on the layer.
2 exludes any overlapping areas where a new path intersects with other paths on the layer.

Multiple path components can be combined into a single element using the Combine button from the options bar.

Blend Modes

Whenever you place pixels over other pixels (painting, layers, fills etc) — Photoshop gives you access to its blend modes. Blend
modes work by looking at the colour of a pixel, and then looking at the colour on top of it, then finally mixing them together
to produce something new.

In blending terminology you have base, blend, and result pixels. If you painted in red over a flat blue background, blue would be
the base colour, red the blend colour and, depending on you blending mode, whatever you'd end up with would be the result.

You can apply blend modes to layers (except a background layer), all painting tools, fills, gradients, patterns, layer effects and
the EDIT>FADE... command.

Normal

No surprises here. No blending takes place unless you count the chance to alter opacity.

Dissolve

Only works on semi-transparent edges — feathered and quick mask selections for instance. Dissolve creates a dithered effect
where Photoshop makes random edge pixels transparent or opaque.

Behind

Works with paint tools, bucket and fill commands. Lets you paint only in the transparent areas of a layer.

Clear

Again only for use with paint tools, bucket and fill commands — the Clear mode has no discernable use — it deletes pixels,
turning them transparent. Just like the eraser, delete key etc etc.

Darken

Looks at the base and blend colour and chooses the darker as the result pixel. This means that any colours that are darker
will be preserved while lighter colours are replaced.

Multiply

Takes the base colour and multiplies it by the blend colour. Forget the maths, the result pixel is always darker than the base
and blend, but usually retaining more detail than the Darken mode.

Colour Burn

Uses the base pixel to produce a colour that’s similar but darker than the blend colour — it does this by increasing contrast in
the base pixels. Leaves whites untouched.

Linear Burn

Uses the base pixel to produce a colour that’s similar but darker than the blend colour — it does this by decreasing brightness
in the base pixels. Leaves whites untouched.

Lighten

Looks at the base and blend colour and chooses the lighter as the result pixel. This means that any colours that are lighter will
be preserved while darker colours are replaced
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Screen

Takes the base colour and blend colour and multiplies them by their inverse! Who knows, that may mean something to you
but as far as the rest of us are concerned the result pixel is always lighter than the base and blend, but usually retains more
detail than the Lighten mode.

Color Dodge

Uses the base pixel to produce a colour that’s similar but lighter than the blend colour — it does this by decreasing contrast in
the base pixels. Leaves blacks untouched.

Linear Dodge

Uses the base pixel to produce a colour that’s similar but darker than the blend colour — it does this by increasing brightness
in the base pixels. Leaves blacks untouched.

Overlay

Screens or multiplies the base colour to create colours which reflect the blend colour, but are lightened or darkened
according to whether they are shadows or highlights.

Soft Light

Similar to Overlay mode in that shadows and highlights in the base are multiplied and screened respectively. Soft Light differs
in that the pixels from the base layer are given more emphasis.

Hard Light

Similar to Overlay mode in that shadows and highlights in the base are multiplied and screened respectively. Hard Light differs
in that the pixels from the blend layer are given more emphasis.

Vivid Light

Another variety of Overlay. Lighter blend colours end up as lighter result pixels. Darker blend colours end up as darker result
pixels. Pixels are lightened and darkened by increasing their contrast.

Linear Light

Still more Overlay variations. Lighter blend colours end up as lighter result pixels. Darker blend colours end up as darker
result pixels. Pixels are lightened and darkened by increasing their brightness.

Pin Light

Yet another Overlay variant. Pin light favours blend pixels. If blend pixels are bright, then pixels darker than them get replaced
by base pixels and lighter than them stay the same. If blend pixels are dark, then pixels lighter than them get replaced by base
pixels and darker than them stay the same.Try it.

Difference

Inverts base pixels according to their blend pixel’s brightness values.White changes to a pixel to it’s negative colour and black
doesn’t change anything at all.

Exclusion

Very similar to Difference, except far less contrasty.

Hue

Uses the Hue component (colour) of the blend pixel to mix with the saturation (richness) and luminosity (brightness) of the
base pixel.

Saturation

Uses the Saturation component of the blend pixel to mix with the Hue and Luminosity of the base pixel.

Color

Uses the base pixels for saturation and luminosity and then adds the blend colour to the result pixel.Very useful for colouring
or re-colouring images.
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Luminosity

Uses the Luminosity component of the blend pixel to mix with the Hue and Saturation of the base pixel.

Layer Styles

All layers except adjustment layers and background layers can have a number of special effects applied to them.These effects,
long with blending and transparency information can be saved and applied to other layers as Layer Styles.

Adding Layer Effects

You can add layer effects a number of ways...

* Via LAYER>LAYER STYLE
*  Click on the Layer Style icon on the Layer Palette ﬁ
*  Double click on the layer in the Layer Palette

Any of these brings up the Layer Style dialog box where you can apply one or more of these settings. Click on the name of
the style (not just the checkbox) to get access to each of the styles full range of settings.

Blending Options

In the General Blending section you can change the blending modes and opacity, just like on the layers palette.
The Advanced Blending modes give you a few more options:

Fill Opacity controls the opacity of the pixels in the layer — but leaves the layer effect intact. (You can choose not to blend
particular channels by unchecking the Channels checkboxes.)

If you’ve bought the fill opacity of a layer below 100% you can use the Knockout settings to show the background layer (or
the bottom layer of a layer set) through the active layer. Use the Shallow setting to see through to the bottom of a layer set
and use Deep to see through to the background layer.

Use the Blend If sliders to blend layer pixels together based on brightness values.

Drop Shadow

Creates a translucent shadow behind the layer content. Drag in the image window to move the shadow manually or use the
Angle wheel and Distance slider.

Spread controls the distance from the layer content that the shadow begins and Size determines the extent of the shadow.
Use the Contour pop-up to create special shadow effects.
The noise slider introduces random diffuse pixels.

Inner Shadow

Creates a shadow that falls within the interior of a layers content.

Most of the settings here are the same as for the Drop Shadow.The only difference is the Choke slider. Choke pushes the
start of the Inner Shadow further into the interior of the layer content.

Outer Glow

Will create a lighter border around the layer contents edges using either a flat colour or a gradient.
Set the Technique slider to Softer most of the time, but if your glow needs to follow tight corners then try Precise.

The range slider, in conjunction with a custom contour setting alters the intensity of the contour effect. When you're using a
gradient glow the jitter slider adds random colours to the glow.

Inner Glow

Inner Glow is just like Outer Glow except the effect is seen on the inside of the layer content.
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Bevel and Emboss

Applies, you've guessed it, Bevel and Embossing effects. Choose a style from the style pop-up but note that Stroke Emboss
only works when a stroke effect has been applied to the layer.

The Technique slider determines how sharply the lines of the effect are drawn. Smooth blends pixels softly around the layers
edges and Chisel Soft and Chisel Hard use hard, sharp lines to create their effects. Use the Soften slider to blur the hard,
sharp lines created with Chisel Soft and Chisel Hard.

To create Embossed and Bevelled effects Photoshop has to calculate a virtual light source that’s illuminating a layer. The
Shading section of the Bevel and Emboss dialog box controls the Altitude and Angle of this light and the Gloss Contour pop-
up creates further special effects.

Satin

Fills the layer with a semi-opaque satin-ish fill that reflects the shape of a layer.

Color Overlay

Fills the layer with a colour.

Gradient Overlay

Fills the layer with a gradient

Pattern Overlay

Fills the layer with a pattern

Stroke

Puts a line around the edges of a layer.

Saving Layer Styles

Share layer styles by right-clicking the layer whose styles you're stealing then using and choosing Copy Layer Styles.Then
select another layer, right-click and choose Paste Layer Styles.

If you fancy something a bit more permanent save your layer styles in the Styles palette (Window>Style) so that you can
come back and use them again. Save your layer styles by selecting a layer whose effects you want to keep and go to Styles
Palette Menu>New Style. Give it a name it’s saved for posterity.

Applying Layer Styles

To apply styles — select the layer you want to be styled. Find the Style palette, find your style, click on it.

Adjustment Layers

An adjustment layer contains tonal and colour correction commands that effect all the layers below it in the layer palette.
Adjustment layers are very useful because a) they allow you apply tonal and colour corrections to several layers at once and
b) they can be turned off, discarded, or tweaked, as the occasion demands.

Adjustment layers can also work like a layer mask. Painting on an adjustment layer in black masks the effects of the adjustment
in that area. White shows the adjustment at full value and intermediate values of grey vary the intensity of the adjustment.

Adding Adjustment Layers

Add adjustment layers with LAYERS>NEW ADJUSTMENT LAYER... or click on the New Adjustment Layer on the
Layers Palette. ),
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Type

Type Layers

Photoshop creates editable vector based type layers with a wide range of typographic controls. Because type is vector
artwork you can make it bigger and smaller and edit it with impunity. However filters require that a type layer is turned into
pixels — rasterizing — and once a type layer has been rasterized it’s no longer editable with the type tools.

The Type tools T lT

Choosing the type tools (either Horizontal or Vertical) takes you into Photoshop’s type mode.
Select the type tool when you want to create or edit text.
Once the type tool is selected the options bar displays a range of typographic choices.

There are two modes, one for free floating independent words or phrases — point type — and another for blocks of words
— paragraph type.

Clicking with the type tool creates point type — type unconstrained by a bounding box.
Clicking and dragging creates paragraph type — type that’ll wrap at the edges of it’'s bounding box.
You can convert between point type and paragraph type using LAYER>TYPE>CONVERT TO...

If you want to create a text bounding box at specific dimensions ALT-CLICK in the image window with the text tool. Fill in
the dimensions in the Text Box Size dialogue box.

The Character and Paragraph Palettes
Fine tune selected type by using WINDOW>CHARACTER or WINDOW>PARAGRAPH

T type size

ﬁ leading (line spacing)

AV . S

~  kerning (space between individual characters)

Ay . ,
*= tracking (letter spacing accross a range of characters)

T

+— horizontal scale

IT vertical scale

Al . . .
=% baseline shift (moves characters above or below the type baseline)

¥ faux bold (fattens a font rather than using a proper bold)

T faux italic (slants a font obliquily rather than using a proper italic)

T 4 caps

small caps
1
T superscript

subscript

I=3

underline

strikethrough
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Warping Type

Distort type layers with these editable presets.To warp your type make sure you've got a type layer and the type tool
selected and look for the 1 on the options bar.

Converting Type into Paths

Change type layers into pure editable vector shapes using either LAYER>TYPE>CREATE WORK PATH or
LAYER>TYPE>CONVERT TO SHAPE, depending on which you need. Edit the paths with the pen tools.

----------

I i R
i
Tt

Both the horizontal and vertical text mask tools create selections using Photoshop’s type engine. Choose the text mask tool
you need and click where you want to make the selection. Photoshop creates a mask overlay so you can see whereabouts
you're putting your selection. Click the ¥ confirm button on the options bar to create a type-based selection.

Colour Settings

Matching colour between original images, different monitors, proofing devices and final output is a very difficult thing to do.
All the devices in a production workflow have limitations on the range and accuracy of the colours that they can produce — as
your document passes along this chain keeping your colours as you intended is a challenge.

A good deal of your success in colour matching is going to depend on the quality (and priceyness) of the equipment you're
using. For relatively accurate on-screen proofing you'll need (at the least) a work environment with stable lighting conditions
and monitors that are calibrated regularly.

Photoshop uses it's own Colour Matching System (CMS) to keep colour consistent between devices, platforms and

output devices. Like most other CMS’s it measures and controls the colours in an image by embedding descriptive profiles

— descriptions of what a colour looked like on a given device — and then manipulating the image data to match those colours
across different environments.

To enable any kind of meaningful colour matching you need to tell Photoshop a few things about your monitor, the colours it’s
generating and where you intend to finally use your images.

Adobe Gamma

Use Adobe Gamma, which you'll find in the Control Panel in Windows and Mac OS 9, but in OS X use the Display Calibrator
from the Utilities folder. Use the Wizard (Step by Step version) or follow the Display Calibrator Assistant until you've saved

a Monitor Profile. If you don’t know the answer to some of the settings consult your monitors documentation or go to the
manufacturers website and look for information there.

Once this has been saved Photoshop automatically loads your profile and embeds it when you save documents.

Colour Settings

Once you've created a Monitor profile open the Color Settings dialogue (Edit>Color Settings...) Choose one of the presets
from the settings pop-up or go on to fill in your own custom settings...

Working Space
Here you tell Photoshop the specific range of colours you intend to use in a given colour mode.
Expensive digital cameras and high quality scans can record a wider range of RGB colours than most monitors can display. It’s

a good idea to tell Photoshop not to clip colours that are out of the range of your monitor’s gamut. Use Adobe RGB if you're
working for print and monitor RGB for the web.

The CMYK, Grayscale and Spot settings deal with how your images are going to printed and the presses and inks that are
going to be used to print them - as such you’ll need to ask your printer what the best settings will be. Photoshop needs these
settings to give you even halfway meaningful CMYK previews.
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Color Management Policies

When Photoshop opens up images it looks for embedded colour information so it can try and keep colour matching between
scans, monitors and final output. The Colour Management Policies are where you tell it how to do it.

The first RGB option is to retain the embedded profile — this is the sensible option — if a document has a profile embedded
it’s probably a good idea to retain it. That said watch out for images from digital cameras and scanners that embed there own,
inappropriate, profiles. Photoshop alerts you if the image you're opening doesn’t match your usual working space.

The other RGB option is to convert straight away into your current working space. Photoshop will alter colours to reflect
your working RGB.

Colour Conversions

You can convert a document’s embedded colour profile by using IMAGE>MODE>CONVERT TO PROFILE...Ifan
image is untagged with no embedded profile you can attach one using IMAGE>MODE>ATTACH PROFILE.

Actions and Droplets

Actions allow you to automate repetitive tasks and create special effects. Similar to macros in other programmes an action is
a series of commands recorded and then played back on demand.

Photoshop comes with a number of preset actions or you can record your own.

Creating Recording and Playing Actions

Before you record an action you first have to create it by clicking on the new action button @l on the Action palette
(WINDOW>ACTIONS). Here you can give the action a name and shortcut key.

Click the record button @ to start recording.You can stop recording at anytime with the stop button ! Resume recording
or add new commands to an action by selecting it and clicking record.

Replay an action with the play button ¥ .

Batch Processing Images

Photoshop allows you to play actions on groups of images, letting you automate repetitive tasks. Use
FILE>AUTOMATE>BATCH... to tell Photoshop which files you want to effect, what you want to do to them and
where you want to save the changed files.

Creating Droplets

Droplets are another automation tool, this time one which embeds an action into an icon.When files are dropped on the
icon Photoshop opens and performs the embedded action.

Create droplets by going to FILE>AUTOMATE>CREATE DROPLET... and tell Photoshop which action you want
to use.
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